If You do not receive an email after registering ,check your spam folder in Your mailbox .
Auto registration in the queue from 5 minutes to 12 hours


If you have problems logging on the forum, write your message in the technical support forum
Registration is not required


Technical support Forum

RTA Trucks Pack Makes My Game Crash at Dealership

Avatar
Topic author
Catdog
VIP
VIP
Posts: 1
Joined: 19.01.2020
Reputation: 0 (+0/−0)
Loyalty: 0 (+0/−0)
With us: 2 years
Flag: Australia

RTA Trucks Pack Makes My Game Crash at Dealership

Unread post #1by Catdog » 31.07.2021, 15:46

Hey there, I've had the Aus Trucks pack for a while now, probably since 1.31 or 1.32 or a bit earlier, I never used to have problems but after 1.39 I started to get this bug where going to buy a truck in the Dealership makes my game freeze instantly and crash. I notice that the images for no trucks at the dealership screen load, not even for vanilla trucks.

I think way back at 1.39 when it first happened, I tried loading in and it crashed so I sold all my RTA trucks, now I can't buy them back to play.
I saw someone else have a similar issue waaaay back in seriously long ago game versions.

Here's what I tried:
- Changing profiles (I have 2) and going to earlier autosaves.
- When this happened in 1.39 I lost interest in the game, so even coming back in 1.40-1.41 with fresh downloads for the newest RTA-mods truck versions still didn't help. I guess I thought it was going to be related to the game patch and it would blow over but it did not.
- I added these launch options per the other forum post of a similar issue: -nointro -mm_max_resource_size 99 -mm_max_tmp_buffers_size 999 (I tried resource size 80 and buffer size 960 first)
because I read in my crash log somewhere it was having some buffer size issues with the T609
- Completely removed Trucksbook.dll from plugins in Steamapps and uninstalled Trucksbook because I saw in the second last line Trucksbook.dll was loading in or something. This did nothing.
- Disabled K200, T609, T908 and WS4800 at one time or another to isolate which truck. Nothing helps.
Consistently throughout the crash log it has errors for missing accessories across most/all the trucks most notably the T609 and K200 things like Engine and Cabin accessories etc.
- I have all RTA-Mods trucks activated in the mod menu to try to see which one caused the crash also with the Cabin accessories mod found in my RTA-Mods zip folder

Any help or ideas appreciated thanks.

Added after 6 minutes 59 seconds:
To Clarify
Game: ATS on latest game version and RTA-Mods 1.40-1.41 trucks
Here is a copy paste of my logs

Game.Crash TXT last few lines and computer specs...
Crash log created on: Sat Jul 31 22:35:21 2021
Build: 1.41.1.10s 86020384df02
OS: x86_64 / Windows 10 x64 (version 10.0)
CPU: Intel(R) Core(TM) i9-10850K CPU @ 3.60GHz at 3600000
MEM: Phys:32656 Virt:134217727
GPU: NVIDIA GeForce RTX 3070 Ti Mem:8041 Ver: 27.21.14.6677
..................
00007FF83AD70000 00657000 00007FF83AEF0BD8 S:\Program FIles (x86)\Steam\steamapps\common\American Truck Simulator\bin\win_x64\tobii_gameintegration_x64.dll
00007FF8A6C40000 00039000 00007FF8A6C5F7C4 C:\WINDOWS\SYSTEM32\RzChromaSDK64.dll
00007FF894660000 00092000 00007FF8946B2760 C:\WINDOWS\SYSTEM32\MSVCP140.dll
00007FF89C2B0000 0004D000 00007FF89C2DCFD0 C:\WINDOWS\SYSTEM32\CONCRT140.dll
00007FF897640000 00019000 00007FF89764F280 C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll
00007FF896E50000 0000C000 00007FF896E54170 C:\WINDOWS\SYSTEM32\VCRUNTIME140_1.dll
00007FF89B8B0000 0002D000 00007FF89B8C455C C:\WINDOWS\SYSTEM32\RzChromaBroadcastManager64.dll
00007FF8B4510000 000CC000 00007FF8B453BE90 C:\WINDOWS\SYSTEM32\DNSAPI.dll
00007FF8A6250000 0000A000 00007FF8A62514A0 C:\Windows\System32\rasadhlp.dll
00007FF8A9FD0000 00141000 00007FF8A9FFCF90 C:\Windows\System32\Windows.UI.dll
00007FF8AEEC0000 000A1000 00007FF8AEED1D70 C:\Windows\System32\WindowManagementAPI.dll
00007FF8AECB0000 00201000 00007FF8AED1C800 C:\WINDOWS\SYSTEM32\twinapi.appcore.dll
00007FF8A0B20000 0007F000 00007FF8A0B25910 C:\WINDOWS\System32\fwpuclnt.dll
00007FF8947F0000 00737000 00007FF894B9B890 C:\Program Files\NVIDIA Corporation\NvContainer\MessageBus.dll
00007FF8A9390000 001E4000 00007FF8A93AB1A0 C:\WINDOWS\System32\dbghelp.dll

Game.log TXT
................
00:00:37.382 : Economy reset - company mismatch
00:00:37.766 : [actor] Initialized at [-98654.5;4.0;-61658.3]
00:00:37.922 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken108/cabin/sound.sui' in the read_only mode.
00:00:37.922 : <ERROR> [unit] File '<D:/Ryan/Documents/American Truck Simulator/mod/ATS_KW_K108_RTA-Mods_v2.8_Part1.scs | >/def/vehicle/truck/ken108/cabin/sleep_a.sii', line 36:
00:00:37.922 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken108/cabin/sound.sui' in the read_only mode.
00:00:37.922 : <ERROR> Failed to open the file '<MISSING><UFS>/def/vehicle/truck/ken108/cabin/sound.sui'.
00:00:37.922 : <ERROR> load_unit() - Failed to load units from file (/def/vehicle/truck/ken108/cabin/sleep_a.sii)
00:00:37.923 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken108/engine/rta_3406e.sii' in the read_only mode.
00:00:37.923 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/ken108/engine/rta_3406e.sii)
00:00:38.029 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken200/cabin/sound.sui' in the read_only mode.
00:00:38.029 : <ERROR> [unit] File '<D:/Ryan/Documents/American Truck Simulator/mod/ATS_KW_K200_RTA-Mods_v15.5_Part1.scs | >/def/vehicle/truck/ken200/cabin/sleep_a.sii', line 42:
00:00:38.029 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken200/cabin/sound.sui' in the read_only mode.
00:00:38.029 : <ERROR> Failed to open the file '<MISSING><UFS>/def/vehicle/truck/ken200/cabin/sound.sui'.
00:00:38.029 : <ERROR> load_unit() - Failed to load units from file (/def/vehicle/truck/ken200/cabin/sleep_a.sii)
00:00:38.030 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken200/engine/rta_n14.sii' in the read_only mode.
00:00:38.030 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/ken200/engine/rta_n14.sii)
00:00:38.328 : Road network navigation caching started.
00:00:38.568 : Cached navigation loaded
00:00:38.576 : Garage update started.
00:00:38.627 : Garage update finished.
00:00:39.053 : [actor] Initialized at [-98654.5;4.0;-61658.3]
00:00:39.053 : Incompatible save loaded. Respawning player truck in safe location...
00:00:39.054 : [actor] Teleported from [-98654.5;4.6;-61658.3] to [-98654.9;4.8;-61657.2]
00:00:39.942 : Incompatible save game loaded.
00:00:46.347 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/kw_t609/interior/animations.sui' in the read_only mode.
00:00:46.347 : <ERROR> [unit] File '<D:/Ryan/Documents/American Truck Simulator/mod/ATS_RTA-Mods_KW-T609_v1.9_Part1.scs | >/def/vehicle/truck/kw_t609/interior/exc_c.sii', line 21:
00:00:46.347 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/kw_t609/interior/animations.sui' in the read_only mode.
00:00:46.347 : <ERROR> Failed to open the file '<MISSING><UFS>/def/vehicle/truck/kw_t609/interior/animations.sui'.
00:00:46.348 : <ERROR> load_unit() - Failed to load units from file (/def/vehicle/truck/kw_t609/interior/exc_c.sii)
00:00:46.348 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/kw_t609/engine/rta_3406e.sii' in the read_only mode.
00:00:46.348 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/kw_t609/engine/rta_3406e.sii)
00:00:46.348 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/kw_t609/accessory/bumper/shape1bk.sii' in the read_only mode.
00:00:46.348 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/kw_t609/accessory/bumper/shape1bk.sii)
00:00:46.348 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/kw_t609/accessory/r_bumper/shape1r.sii' in the read_only mode.
00:00:46.348 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/kw_t609/accessory/r_bumper/shape1r.sii)
00:00:50.153 : <ERROR> Missing accessory (/def/vehicle/truck/ken108/cabin/sleep_a.sii) replaced by (/def/vehicle/truck/ken108/cabin/sleep_a.sii).
00:00:50.153 : <ERROR> Missing accessory (/def/vehicle/truck/ken108/engine/rta_3406e.sii) replaced by (/def/vehicle/truck/ken108/engine/rta_3406e.sii).
00:00:50.154 : <ERROR> Engine accessory is missing!
00:00:50.154 : <ERROR> Cabin accessory is missing!
00:00:50.177 : <ERROR> Missing accessory (/def/vehicle/truck/ken200/cabin/sleep_a.sii) replaced by (/def/vehicle/truck/ken200/cabin/sleep_a.sii).
00:00:50.181 : <ERROR> Missing accessory (/def/vehicle/truck/ken200/engine/rta_n14.sii) replaced by (/def/vehicle/truck/ken200/engine/rta_3406e.sii).
00:00:50.182 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken200/engine/rta_3406e.sii' in the read_only mode.
00:00:50.183 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/ken200/engine/rta_3406e.sii)
00:00:50.184 : <ERROR> Engine accessory is missing!
00:00:50.187 : <ERROR> Cabin accessory is missing!

Added after 10 seconds:
To Clarify
Game: ATS on latest game version and RTA-Mods 1.40-1.41 trucks
Here is a copy paste of my logs

Game.Crash TXT last few lines and computer specs...
Crash log created on: Sat Jul 31 22:35:21 2021
Build: 1.41.1.10s 86020384df02
OS: x86_64 / Windows 10 x64 (version 10.0)
CPU: Intel(R) Core(TM) i9-10850K CPU @ 3.60GHz at 3600000
MEM: Phys:32656 Virt:134217727
GPU: NVIDIA GeForce RTX 3070 Ti Mem:8041 Ver: 27.21.14.6677
..................
00007FF83AD70000 00657000 00007FF83AEF0BD8 S:\Program FIles (x86)\Steam\steamapps\common\American Truck Simulator\bin\win_x64\tobii_gameintegration_x64.dll
00007FF8A6C40000 00039000 00007FF8A6C5F7C4 C:\WINDOWS\SYSTEM32\RzChromaSDK64.dll
00007FF894660000 00092000 00007FF8946B2760 C:\WINDOWS\SYSTEM32\MSVCP140.dll
00007FF89C2B0000 0004D000 00007FF89C2DCFD0 C:\WINDOWS\SYSTEM32\CONCRT140.dll
00007FF897640000 00019000 00007FF89764F280 C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll
00007FF896E50000 0000C000 00007FF896E54170 C:\WINDOWS\SYSTEM32\VCRUNTIME140_1.dll
00007FF89B8B0000 0002D000 00007FF89B8C455C C:\WINDOWS\SYSTEM32\RzChromaBroadcastManager64.dll
00007FF8B4510000 000CC000 00007FF8B453BE90 C:\WINDOWS\SYSTEM32\DNSAPI.dll
00007FF8A6250000 0000A000 00007FF8A62514A0 C:\Windows\System32\rasadhlp.dll
00007FF8A9FD0000 00141000 00007FF8A9FFCF90 C:\Windows\System32\Windows.UI.dll
00007FF8AEEC0000 000A1000 00007FF8AEED1D70 C:\Windows\System32\WindowManagementAPI.dll
00007FF8AECB0000 00201000 00007FF8AED1C800 C:\WINDOWS\SYSTEM32\twinapi.appcore.dll
00007FF8A0B20000 0007F000 00007FF8A0B25910 C:\WINDOWS\System32\fwpuclnt.dll
00007FF8947F0000 00737000 00007FF894B9B890 C:\Program Files\NVIDIA Corporation\NvContainer\MessageBus.dll
00007FF8A9390000 001E4000 00007FF8A93AB1A0 C:\WINDOWS\System32\dbghelp.dll

Game.log TXT
................
00:00:37.382 : Economy reset - company mismatch
00:00:37.766 : [actor] Initialized at [-98654.5;4.0;-61658.3]
00:00:37.922 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken108/cabin/sound.sui' in the read_only mode.
00:00:37.922 : <ERROR> [unit] File '<D:/Ryan/Documents/American Truck Simulator/mod/ATS_KW_K108_RTA-Mods_v2.8_Part1.scs | >/def/vehicle/truck/ken108/cabin/sleep_a.sii', line 36:
00:00:37.922 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken108/cabin/sound.sui' in the read_only mode.
00:00:37.922 : <ERROR> Failed to open the file '<MISSING><UFS>/def/vehicle/truck/ken108/cabin/sound.sui'.
00:00:37.922 : <ERROR> load_unit() - Failed to load units from file (/def/vehicle/truck/ken108/cabin/sleep_a.sii)
00:00:37.923 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken108/engine/rta_3406e.sii' in the read_only mode.
00:00:37.923 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/ken108/engine/rta_3406e.sii)
00:00:38.029 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken200/cabin/sound.sui' in the read_only mode.
00:00:38.029 : <ERROR> [unit] File '<D:/Ryan/Documents/American Truck Simulator/mod/ATS_KW_K200_RTA-Mods_v15.5_Part1.scs | >/def/vehicle/truck/ken200/cabin/sleep_a.sii', line 42:
00:00:38.029 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken200/cabin/sound.sui' in the read_only mode.
00:00:38.029 : <ERROR> Failed to open the file '<MISSING><UFS>/def/vehicle/truck/ken200/cabin/sound.sui'.
00:00:38.029 : <ERROR> load_unit() - Failed to load units from file (/def/vehicle/truck/ken200/cabin/sleep_a.sii)
00:00:38.030 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken200/engine/rta_n14.sii' in the read_only mode.
00:00:38.030 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/ken200/engine/rta_n14.sii)
00:00:38.328 : Road network navigation caching started.
00:00:38.568 : Cached navigation loaded
00:00:38.576 : Garage update started.
00:00:38.627 : Garage update finished.
00:00:39.053 : [actor] Initialized at [-98654.5;4.0;-61658.3]
00:00:39.053 : Incompatible save loaded. Respawning player truck in safe location...
00:00:39.054 : [actor] Teleported from [-98654.5;4.6;-61658.3] to [-98654.9;4.8;-61657.2]
00:00:39.942 : Incompatible save game loaded.
00:00:46.347 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/kw_t609/interior/animations.sui' in the read_only mode.
00:00:46.347 : <ERROR> [unit] File '<D:/Ryan/Documents/American Truck Simulator/mod/ATS_RTA-Mods_KW-T609_v1.9_Part1.scs | >/def/vehicle/truck/kw_t609/interior/exc_c.sii', line 21:
00:00:46.347 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/kw_t609/interior/animations.sui' in the read_only mode.
00:00:46.347 : <ERROR> Failed to open the file '<MISSING><UFS>/def/vehicle/truck/kw_t609/interior/animations.sui'.
00:00:46.348 : <ERROR> load_unit() - Failed to load units from file (/def/vehicle/truck/kw_t609/interior/exc_c.sii)
00:00:46.348 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/kw_t609/engine/rta_3406e.sii' in the read_only mode.
00:00:46.348 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/kw_t609/engine/rta_3406e.sii)
00:00:46.348 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/kw_t609/accessory/bumper/shape1bk.sii' in the read_only mode.
00:00:46.348 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/kw_t609/accessory/bumper/shape1bk.sii)
00:00:46.348 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/kw_t609/accessory/r_bumper/shape1r.sii' in the read_only mode.
00:00:46.348 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/kw_t609/accessory/r_bumper/shape1r.sii)
00:00:50.153 : <ERROR> Missing accessory (/def/vehicle/truck/ken108/cabin/sleep_a.sii) replaced by (/def/vehicle/truck/ken108/cabin/sleep_a.sii).
00:00:50.153 : <ERROR> Missing accessory (/def/vehicle/truck/ken108/engine/rta_3406e.sii) replaced by (/def/vehicle/truck/ken108/engine/rta_3406e.sii).
00:00:50.154 : <ERROR> Engine accessory is missing!
00:00:50.154 : <ERROR> Cabin accessory is missing!
00:00:50.177 : <ERROR> Missing accessory (/def/vehicle/truck/ken200/cabin/sleep_a.sii) replaced by (/def/vehicle/truck/ken200/cabin/sleep_a.sii).
00:00:50.181 : <ERROR> Missing accessory (/def/vehicle/truck/ken200/engine/rta_n14.sii) replaced by (/def/vehicle/truck/ken200/engine/rta_3406e.sii).
00:00:50.182 : <ERROR> [fs] Failed to open file '/def/vehicle/truck/ken200/engine/rta_3406e.sii' in the read_only mode.
00:00:50.183 : <ERROR> load_unit() - Failed to open file (/def/vehicle/truck/ken200/engine/rta_3406e.sii)
00:00:50.184 : <ERROR> Engine accessory is missing!
00:00:50.187 : <ERROR> Cabin accessory is missing!

Added after 1 minute 26 seconds:
Files
You do not have the required permissions to view the files attached to this post.

Return to “Technical support”

Who is online

Users browsing this forum: 1 guest